Fiverr Community Forum

Cannot Publish Gig Due to W9

Hey All,

New to Fiverr here. Trying to publish my first gig and I get to the last step which requires me to fill out the W9 as I am a US Citizen, that’s fine. I fill it out and get the confirmation (seven times I might add) that I completed it and am good to go. However, I am not able to publish, it keeps only giving the option to update my W9 which keeps telling me I’m good to go. #WhatIsGoingOn

10 Likes

Hi nelan 1234
Please Create New Gig.
and start your journey.
I hope solved your all problem
Thanks for share problem
wpmdyeasin

2 Likes

wpmdyeasin,

Thank you for your response, however, I just tried that and it did not fix the issue.

1 Like

Please try perfectly

I’m not sure what you mean by “try perfectly”.

3 Likes

Hi Nelan1234, I had this issue over the weekend when I signed up Sat night. I reached out to Support and was told they knew about the issue and it wasn’t until yesterday morning at 9am the problem was resolved and I received notification that my W-9 was validated and I was good to go.

Contact Customer Support and fill out a ticket. They may not even know it’s not working again. But, they did know there was a problem over the weekend and it took a day and a half before it was resolved. Good luck.

4 Likes

I’ll go try that. Thanks!

They were fairly responsive. Keep your eyes on your notifications too. You will receive one once it’s working again.

Good luck.

3 Likes

For anyone reading this thread, I eventually got an additional email also telling me that my W9 was confirmed but this time it said that it was reviewed and approved by Tax Authorities, so if you’re having this same issue just give it a few hours.

13 Likes

thank you. I’m having the same issue.

Yeah this is still broken. I’m trying to post a gig and even though my w9 is updated, I cannot publish. It is failing in firefox and safari on a mac. Can’t believe they would just let this sit broken

I am having the same exact issue with publishing my gig. “Publish” button is grayed out and it’s stuck on the W9 page. I’ve sent a message to support. I’ll let y’all know if I find a solution.

Try perfectly. Lol. Did it work?

4 Likes

This is happening to me too. Any solutions? Do we just have to wait and try later? what is the dealio? Thanks!

1 Like

Currently having this exact problem. I tried perfectly and everything! Going to wait a few hours and try again.

2 Likes

Did you try other browser or maybe cleared the cache from your current browser?

Reading this entire thread, the answer to the “dilemma” of not being able to publish your Gig due to some bug in Fiverr’s system when it comes to submitting your W9 is getting in touch with Customer Service - that is the only thing in this thread that has worked for someone having this issue.

Submitting “perfectly” is nonsense - not sure what that poster is even talking about and I bet he doesn’t either!

If you have this issue, create a ticket with Customer Service so they can look at your account and fix this for you already!

GG

Why is this still happening? I’ve been trying for days.

Dang they’re still having this problem, huh? How else did I find this thread if I wasn’t having issues.

Got the same issue ;(