Can't withdraw! Help!


#1

Literally, every single time I’ve tried to withdraw for about the past 10 times - the options to withdraw are all greyed out leaving me unable to withdraw, stating that there is a withdrawal in process! I’ve contacted Fiverr customer support, and ended up getting a warning for doing so as a glitch meant the message was sent a huge number of times. Obviously the Fiverr system has glitches as shown by the fact that I am unable to withdraw everytime! It’s so unreasonable that the only replies received from @customer service@ seem to be BOT replies! I was then told that my account would be refreshed - as a result I’ve had very very few orders and think as a result of refreshing, my account will have slipped down the rankings. Anyone else have any experience with this as it’s so frustrating.

*If I get told to clear my browser and cookies again I’m going to scream - it’s a problem on Fiverrs side - not mine!!!


Why spam? Any guidance
#2

best thing is to go into fiverr.zendesk.com and try to get one of your original support requests escalated, so they know you already tried to clear your browser cookies.

make sure to be polite. I know you must be super frustrated… but displaying anger to CS will not help.