Fiverr Community Forum

'Deliver Work' greyed out, or link just not working?

Hey guys, anyone else having trouble with the delivery box? Just came to deliver an order and the ‘Deliver Work’ button seems to be sort of greyed out, or I’m just seeing things - either way, it doesn’t seem to be linking and opening the message box up. Also, the ‘message’ and ‘resolve issues’ links at the very bottom are also not doing anything for me.

Any ideas?

Same here

Is doing the same for me- whew! glad is not something I did wrong. But really need to deliver an order and don’t know what to do!

Try to deliver again with a minimum of words, no links, and a simple file.

I’m having the same issues… glad to know it’s not just me… Sent fiverr support message and then checked here… I was trying to send a client a message regarding her order but I can’t do that… I hope they get it fixed soon.

Was doing this for me i refreshed the page and it worked

Reply to @shawnecannon: I tried the refresh the page button and it worked… much appreciated. :slight_smile:

Reply to @emeraldawnn: glad I could help :slight_smile:

Just had a seller who was trying to contact me about an order complaining of the same thing , so it hasn’t been entirely solved yet. It can’t be reasonable to expect everyone to Ctrl+F5, and everyone else who doesn’t know that little trick is just left in the dark. Contacted support and they aren’t finding a problem in Chrome or Firefox. Hmm…

Same but different - I’m trying to add a new gig and edit an existing one, and in both cases the ‘save’ button is greyed out.

Couple that with a lot of ‘backrub mode’ and 503 errors over the last few days, and it does look like there’s something afoot in the engine room.

Cant send messages to buyers, send button greyed out!

I dont have any issues at the moment :open_mouth:

It is happening to me too. I can not deliver my work due in few hours time.

Please what can one do to solve this.

Well fiverr said it’s a tech problem from their end.

Hope it will not have adverse effect on the order delivery?

Hi, I’m not able to deliver my order because the DELIVER YOUR ORDER button is not working and my order time is finishing in one hour. What should I do now.
Please help.


Lates topic on similar issue :arrow_right: I can't deliver any order .