Fiverr Forum

Delivering files - Browse button greys out for 10 seconds and then goes blue again


#1

Anybody else have this? I want to deliver a file. I click on the Browse button. It goes grey for about 10 seconds and then back to blue again without bringing up the file selection box - so I am unable to attach. I can get round this by clicking on the “having problems” option but there I canot select multiple files nor upload to my portfolio. I have tried Chrome, Safari, Chrome incognito, re-boot, Fiverr support - but I still get it. Is it just me?


#2

Jane - If I had a dollar for each time I re-tried it I’d have… oh about 6 dollars.


#3

I’ve just tried it again - 0n a PC this time (I use a mac) and same problem. Actually I just re-read my description above and i made a small mistake - I click browse and it DOES bring the file selection box but when I select the file, all that happens is the browse button goes back to blue and no file is attached. Fiverr support seem to think it’s a problem with my setup - but now I have tried with multiple browsers and different hardware.


#4

Nothing invented by humans can have 100% efficiency.

Just be patient to retry another time over and over again or better still do what Madmoo suggested.