Fiverr Forum

Entire site is intolerably slow

Typing in almost any textbox takes 15 to 30 seconds for the text to show up (including this one). Clicking on almost any menu or nav item takes forever for anything to happen. I don’t have a problem with other sites. I’m using Chrome and this scenario is incredibly consistent, even after rebooting my machine (Windows 10). If I’m stupid enough to try for more than twenty or so minutes, Chrome will tell me your entire site has simply stopped responding and I’ll have to kill whatever script is out of control on your site.

If it helps, the following calls are taking about 25 seconds each…
Request URL:
https://forum.fiverr.com/message-bus/c68be6113dbe4103869cbd205531a681/poll
Request Method:
POST
Status Code:
200
Remote Address:
64.71.168.222:443
Referrer Policy:
no-referrer-when-downgrade

My experience with fiverr is basically that your site is completely unusable.

Are you sure this isn’t only happening to you?

Everything on my end is working fine…but I once heard that not everyone is on the same server – if it is true that Fiverr has different servers for different locations, maybe they vary in performance.

Though that might be true, there being such a noticeable difference in load times is not likely. I recommend clearing the browser cache and cookies to see if it helps.

Everything on my end is working fine but when I do have issues, the cache thing is the first thing i do.

1 Like

Clearing the cache certainly helps, but only for a short time. Perhaps it has to do with a Chrome plugin I have or something. The behavior points to some sort of memory leak, but I don’t have time to troubleshoot their client code.