Fiverr Forum

Fiverr website not loading properly


#1

Hi,

The Fiverr website is not loading properly on all browsers on my machine over the past few days. It is the ONLY website that I am having challenges with. I have cleared cookies, browsing history and cache. I have flushed DNS, deleted Temp Folder and changed IP to Google. Nothing seems to be working. I have attached a screenshot of what the website looks like when I try to load it. PLEASE HELP. I have work to give people to do for me.


#2

What OS are you using?


#3

I am using Windows 10


#4

Darn, that shoots down one theory. You aren’t the only one having this problem but someone else said it happened to them on 7 but not on 8 or 10, so I was hoping that was related. I’m sorry, but all I can suggest for now is to try a couple of things I haven’t heard back on and one other that I found on another troubleshooting site. Here are the ideas I haven’t confirmed as working or not:

Try going to uk.fiverr.com instead of just fiverr.com
Try a mobile browser if you have access to one (not the mobile app, but a browser)
Try creating a new Windows user profile and see if you can get to Fiverr under a brand new profile.

Edit: I’m adding this as one last thing of note. Of the people I’ve seen with this issue all but one have buyer profiles (no gigs) and have no Country listed on their profile. You might try adding your language and don’t use any kind of proxy server or anything that might cause your location to be missing or incorrect.


#5

Thank you for your response.

I am having the same problem with uk.fiverr.coM

The website is also not working on my mobile browser

Same issue with a new windows user profile

I do not have any gigs, I am a buyer and my country is listed on my profile.

The website is appearing the same way on my mobile phone.

I have tried other laptops and mobile phones and the results are the same


#6

It’s some kind of programming error with the way the pages load.