Great. Now I have to change both the language AND the currency every time I log


#1

When it was just the language, I posted a couple of times in the suggestion box, but it’s no longer considered a feature, it’s now a full on glitch for me and anyone who travels often or lives abroad.

Please save the language and currency settings per user or at least per browser so we don’t have to set them every time we load the site. It’s a real productivity killer.


#2

Have you tried clearing your browser cache/cookies and then resetting your language and currency? I haven’t tried it with that exact issue, but when I had an edited gig that didn’t seem to reset that worked for me.


#3

Thanks for the reply. Well no, but I have the same issue on at least 3 devices so I don’t think it’s device-specific.