Fiverr Forum

Hey Fiverr, your site's dying. Enough Bugs Already


#1

This has really been frustrating. Ever since Fiverr made site changes in late-September/ early-October this site has become more bug-ridden each day. I find I’m having to make at least 2-3 support requests to CS each week. Before September, I made perhaps 2 support requests in 2 years. How is this not costing them money?

And the bugs are all over the place too. I just delivered 10 separate orders to a longtime buyer that says the orders show as still undelivered on his end, and they show delivered on mine. Last night another longtime buyer gave me a 5-star review, today it’s marked as a modification request with the same “great job” message in the mod request that was in the 5-star review.

These aren’t scammers pulling shenanigans, these are folks I’ve worked with for a long time on Fiverr.

-Email notifications sometimes come through, sometimes don’t.
-My to-do list doesn’t update, or does so hours after the gigs are completed or updated.
-Messages and replies are just lost. Poof, gone into oblivion.
-Marking a message as spam DOES NOT prevent the “buyer” from further bothering me.

For goodness sake, roll the darn site back to the end of September, when it actually worked.
And have a serious talk with whoever your new lead developer is. (It’s OBVIOUSLY a new person, because it’s NEVER EVER EVER been this bad on Fiverr.)

Want to know why your support cue is so busy? Your site is BROKEN. Badly.


#2

I feel your pain. It’s comforting to know that I am not the only seller here who has been experiencing an onslaught of bugs recently, though I don’t wish this aggravation on anyone else. Customer Service has been atrocious. They don’t fix anything and keep marking my requests “solved” when they are not solved. I’m considering closing my account here; I’ll just give them a bit more time to get their act together.


#3

No big deal. Bugs and great technology go together, but I am sure that Fiverr will never die.


#4

Wow, CS made me think it was my problem, I thought I was the only one.


#5

I just opened an account and I’ve experienced more bugs already that I can’t even get my business here started.
i can’t post a new topic in the forums so I’m glad I found this post. I did every thing I was supposed to do and it still doesn’t let me post a question. I’m trying to get an answer here because already, I’m getting my problem sent to oblivion in some other department.
When I try to post to the forum, I get the Forum ID Missing error. No matter what I do, I can’t post a new question.
Another bug I have is that I only added 3 gig photos and was going to post a lot more but there is no more plus buttong to add anymore photos. So more potentional buyers only get to see 3 samples. i’ll never get a sale that way.
i have never seen a sight this disfunctional before.


#6

My goodness. Another bug. I was going to correct a couple words in my post so I clicked on edit and I can’t scroll down in the box to get to the text I need to change. Well i’ll have to settle with the misspelled words.


#7

It’s comforting to know I am not the only one with delivery issues.

I am very new here - for the first week all my deliveries delivered perfectly first time.

Now they show as delivered in the timeline of the order, but the order doesn’t move to the “delivered” folder, the clock keeps ticking and the customer does not receive the delivery.

The only deliveries I can get to ACTUALLY deliver, and close the order, are empty ones - ones with no attachments.

So I’ve been sending empty deliveries, then delivering the orders as attachments to “update” messages, which do go through.

I find it terrifying that an order can appear to me as successfully delivered and yet the customer receives nothing.


#8

I finally just took all my gigs offline because the site won’t seem to let me save my gig extras. One day I noticed they had all disappeared so I painstakingly added them all back, only to discover that they are not being saved. Viewing my gigs only showed one, or maybe two gig extras at most. Wow, very buggy to the point of being unusable. I’ll be on the sidelines until it gets fixed.


#9

Now I’m totally unable to deliver anything.

Not even my “empty” delivery work-around works any more.

I have all my orders completed, but the system won’t deliver anything.

I’m now totally stuck with the countdown clocks ticking away on the orders, all the stuff I need to deliver sitting here ready to go, and no way to deliver them and stop the clock.

I am beyond stressed and upset.


#10

I totally agree with all the posters in this thread- the site has become unusable. Fortunately for me though, I am active on several other platforms, so I deleted all my gigs. I will now hang about on the sidelines to see how things either improve, or deteriorate. In all fairness, I must all say that Fiverr has been very good to me, and I will definitely be back once the bugs are resolved.


#11

A few months later…has this been resolved? New seller and concerned.


#12

I don’t have any problem using it.