I cant get in touch with fiverr support


#1

Does anyone know Why from yesterday i can’t Submit A Request on fiverr support (it popup a message saying “Delivery failed please try again” and nobody answer me on facebook messenger and on twitter official pages? how i can get it touch with some one in fiverr?


#2

Hi,

If the normal “submit a request” option doesn’t work, you can try sending them an e-mail at support@fiverr.com :pineapple:


#3

Give it some time.
Might be from poor internet service.


#4

im trying from yesterday


#5

I am not sure if you were responding to my message or someone else’s, but sending them an e-mail at support@fiverr.com has always worked for me.


#6

This is true, try using support mail.


#7

thank you hanshuber16. do you believe that someone will answer me in this email?


#8

thank you. i will try that


#9

Absolutely!

As soon as you send them an e-mail at the given address, you also receive a support ticket number issued for the e-mail sent and they will hopefully get back to you as soon as they can.


#10

There were a number of people having this issue yesterday, although most or all of them resolved it by trying again later or taking these steps:

Try this:

  • Clear all your cookies or at least the ones for Fiverr.
  • Do the same with cache.
  • Restart your browser.
    Look to see if that fixes your problem. If not, do the same steps and also restart your computer before you restart your browser.

If that doesn’t work and you are not using Chrome, try submitting a ticket with Chrome and if necessary, repeat the steps above with Chrome.

If that still doesn’t work, try support@fiverr.com as @hanshuber16 suggested. The email should be a last resort as it’s not reliable.


#11

Good to know. I tried with multiple browsers. Not eager to reboot. :slight_smile:


#12

Are you having trouble submitting tickets too?


#13

ayup

I tried in two different tabs, and then a different browser before I gave up :blush:


#14

Hmm. It seemed like it was mostly resolved yesterday but this sounds like it may have cropped up for several people again. I don’t know if it will help but I’ll forward the issue again.


#15

I had this issue last week and the only thing that resolved it was changing the category of the help type - the new category didn’t make sense for my issue, but it was the only way I could get the ticket to submit and not give me the delivery failed please try again message. I had to try several time to get a ticket category that worked. Hopefully it will be fixed soon if not already!