Fiverr Community Forum

Id verification failed and account temporarily disabled

Hi,
My id verification failed multiple times and eventually my account was temporarily disabled.
I think It failed because, there was only a passport Id verification option for my country(Nepal). I don’t have a passport yet. So, I submitted my citizenship card which is also a government id. And, I cannot go now and apply for passport Id because of the COVID crisis and everything is shut down in strict lockdown. Or maybe because of the picture quality?

I think my message to Customer support went on spam because I sent the message twice. It has been more than 4 days now, I have not got a reply from Customer support. I’m very panicked. If I lose my id and my works I’ll be in a big problem at this time of lockdown.
Can I get the attention of Customer support here? Or is there any way I can contact customer support besides mailing, because it might not work if my message was sent to spam.
I really hope that my problem could be solved as soon as possible. I’m a full-time freelancer with honest work ethics.

4 Likes

Unlikely, no. Fiverr customer support does not hang out on the forums. Those of us here are just fellow sellers/buyers, just like you. We have no access to your account to assist you with this. The only way you’ll find any resolution on this is to be patient, and talk to CS via the tickets system.

Thank you. But is there a chance for my ticket message to be seen even if it’s sent to spam?

To be honest, if Fiver, for some reason, views your messages to them as spam, then yes, it may be likely that they would choose not to respond. If you’ve sent any messages to Fiverr CS so far, please be patient, and they will respond if and when they are able.

1 Like

They communicated well with me and my issue. Thanks!

1 Like

Hi aasmii.
Can you please tell me how they solved your issue and how did you send the photo of your official ID? My account has been temporarily disabled for the same reason.
Thank you.

Is your account verified now? If so what are the process? please let me know
I have the same issue.

How long did it take ? Is been 2 days and they haven’t responded yet.

There is no need to resuscitate old threads asking the same question. Their experience (if they even visit the forum anymore will probably be different than yours). Also, you got a time frame from another forum user in the last day as to their experience.

I would wonder how you wrote your message to customer service? The other poster got quite a quick response, but you are still waiting. May have to do with how you worded your query - I do not know.

Since the pandemic, there are times when the load of messages for customer service are at a high, and it could take longer to get back to you. Whatever you do, do NOT create new tickets because you are impatient. That is a good way to get ignored. I would say if you have not heard from anyone in 10 days, perhaps send another message (not a NEW one, but one attached to the message or ticket you have open) to them.

GG

1 Like

Thank you for your response

1 Like