Fiverr Forum

Seller Support Bug?


#1

Good day everyone,

I have been trying to contact Fiverr’s support using this link (fiverr.com/support_tickets/new) for the last 4 days, unfortunately, every time I try to submit the request it says “Delivery failed, Please try again”.

I have sent a direct email to the known support team’s address three days ago, but I got no replies yet.

Any suggestions on what should I do to fix this or are there any other ways to submit a support request?

Thanks in advance guys.


#2

I don’t know of a fix but just wanted to let you know that I’m having the same issue. Is anyone able to contact Fiverr support at the moment?


#3

Same here, delivery failed


#4

keep waiting , I think they fix that bug soon


#5

Same here. Is there any workaround?


#6

After waiting for a few days, I have sent another direct email and they have responded quickly.
So, for some reason, they did not get my first email.

Regarding the support ticket utility on the website (fiverr.com/support_tickets/new), it still does not work and if anyone that works with the development team and can fix it or know how to contact them should do so.

Good luck everyone.


#7

This is frustrating! It has now been 11 days since you initially posted this Bug message and it hasn’t been fixed yet.

I tried posting a ticked yesterday and today to Fiverr CS help center and got the same “Delivery failed, Please try again” message. I have tried sending the message through 3 browsers with the same results.

We’re supposed to respond to buyers within 24 hours to confirm that we received their order, but I can’t send my message to my buyer either. I’m not sure, but… I think CS has pulled my confirmation buyer message for further review before sending it on to the buyer. But my buyer hasn’t received the message yet. If I can’t get a ticket into Fiverr to report this issue, I’m stuck. I’ll probably be sucked into Fiverr’s response rate demotion even when it’s Fiverr’s fault.

I have sent a direct email message to support@fiverr.com. I guess we’ll see if I get a response from them this way. Keeping my fingers crossed.