Fiverr Forum

Unable to review or ask for revision for my order


#1

Had a gig order delivered and could download it.The problem is I tried to make a review by pressing the ‘Yes,I’m pleased’ sign,nothing happened as it supposed to take me to the page for me to rate.It’s a new setting detailing the order,unlike the old ones I had no issues.Tried to contact the customer service,but when pressed the send request sign after filling in details of problem,nothing happened.


#2

Sometimes, CS suggests using a different browser, and/or clearing the cache and trying again.

Please let us know if you have an update.


#3

As ammarshrf has suggested, please try using a different browser and let us know if that helps.


#4

Thanks for your replies and suggestions.I have tried clearing the cache first,but it did not work.Then I downloaded Google Chrome and I am happy to say that it has worked.Once again thank you.:smiley:


#5

For future reference: Fiverr is optimized for Google Chrome (or at least that’s what they used to say), and it usually works best in Chrome. :slight_smile: