Fiverr Forum

Unable to verify my ID

Hello. I was told to verify my identity on fiverr. I have been trying to do so for a week now. I get a link in my email and each time l click on the link, rather than take me to the page where l can upload my ID, it returns me to the page that tells me to use a qr scanner or click on a link to get another link sent to my email.
I have contacted customer service and so far, l am yet to get the issue resolved. It’s really making me feel bad.
Has anyone encountered this sort of challenge before? How did you solve it? Any tips on what l should do other than contacting customer service? Any help l can get right now would be greatly appreciated. Thanks alot.

2 Likes

You can contact on Fiverr help (https://www.fiverr.com/support_tickets/new). I hope you will accurate help from Fiverr.

Hi, I am having the same problem. Did it ever get resolved? I’ve heard back from customer services and they told me to clear my cache on my mobile and update my browser, which I’ve done but it still isn’t working. Not many days left to verify. They asked me to send a screenshot of the problem too but there wasn’t any way of doing that on the reply.

Hope it got sorted for you!

Thanks,
Dani

Hi Dani,

So, what’s the problem you’re facing?

What happens when you scan the QR code (or) click on the link provided in the email with your smartphone? Please remember, it will only work if you use a smartphone to scan the QR code (with a QR scanning App) or click on the link provided in the email.

If it keeps taking you back to the page that tells you to scan the QR code, you could try going to the following link directly and then following the instructions provided there:

https://www.fiverr.com/id_verification/info

[NOTE (for others reading the post): Do not click on the above-mentioned link if you haven’t already gotten the notification asking you to verify your ID on Fiverr. Thanks.]

Please let me know if that’s of any help. :slight_smile:

You can also check my post in which I have given a detailed description of my entire Fiverr ID verification process:

1 Like

Hey,

Thanks for replying to my comment!

So the QR code when I scan with my iPhone will take me to the page to select ID type but I can’t actually select any of them.

Same thing happens with the link you sent, it takes me to the page where you can select your ID but I can’t actually select any of them. This is progress from the email link that just takes me to the button that says ‘verify id’ but doesn’t do anything.

It’s just like nothing is linked for me to click on. Maybe it’s the type of phone I have? I’ve downloaded google on my
phone and tried it in there, updated cache etc… should I see if I can try it on my partners android phone?

Really appreciate your help, thanks!
Dani

1 Like

Yep, I think it is a good idea to see if it’s any different on the Android OS. Try accessing the link (that I had mentioned in my previous post) on an Android phone. I used an Android phone for my verification process. I hope you’re able to succeed.

Good luck!

Edit:
@daniellewebber I am glad that it worked out for you in the end. Happy selling! :slight_smile:

Ok cool, I’ll try that later and update on here if successful!

Thanks for your help :slight_smile:

Dani

Update - I have now verified my ID - at last! I had to use my partner’s android phone and it all went through fine! So just seems to be a problem with iPhone, might not be all makes but it wouldn’t work on iPhone for me, so if you’re reading this and having the same problem that might be why.

3 Likes